The Technology database of Duke Yin

错误:不需要升级 您的wordpress数据库已经是最新的了

有天打开Wordpress后台后自动跳转到升级页,提示:
“不需要升级 您的wordpress数据库已经是最新的了”

无论访问后台的哪个页,都会跳转到这个提示,点继续依然还是回到这里死循环。

一查是我在服务器装了Memcached缓存,极可能是缓存把更新页数据当成缓存存起来了,所以必须要先清空缓存,然后才能进后台。

两种方法,

第一种是直接连Linux管理终端
telnet localhost 11211 flush_all 即可

第二种,先把Wordpress的wp-content下的object-cache.php重命名成其他名字,现在发现可以进后台了;紧接着安装WP Memcached Manager 插件,配置好Memcached服务器IP(自己服务器的内网IP即可),然后Flush memcache一下,再把刚刚重命名的文件还原成object-cache.php,问题就解决了。